FlexiCapture Cloud US - Performance Degradation

Incident Report for ABBYY

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 21:50 UTC

Monitoring

Our system's metrics are showing stable and processing times should have improved. We will continue to monitor the system.
Posted Sep 17, 2025 - 20:47 UTC

Update

Our systems remain operational, though some customers may experience slow processing times. We are actively investigating and will provide updates as we work to improve performance.
Posted Sep 17, 2025 - 17:57 UTC

Investigating

We have observed performance degradation in FlexiCapture Cloud US. Analysis is currently in progress.
Posted Sep 17, 2025 - 17:08 UTC
This incident affected: FlexiCapture Cloud US.