Vantage Cloud EU - Performance Degradation

Incident Report for ABBYY

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 17:38 UTC

Monitoring

Our teams have implemented improvement measures and we are continuing to closely monitor the environment.
Posted Nov 03, 2025 - 16:37 UTC

Investigating

We are currently observing elevated database utilization in Vantage Cloud EU, based on internal monitoring indicators. Processing remains operational, however some customers may experience slower than usual performance.
Our teams are actively investigating potential contributing factors and we will provide an update as soon as more information is available.
Posted Nov 03, 2025 - 15:22 UTC
This incident affected: Vantage EU.