Vantage 3 EU - Processing Delays

Incident Report for ABBYY

Update

We are continuing to work on the fix, and we will keep you posted as and when we have further updates.

Next Update will be at 8:00 AM UTC.
Posted Jun 25, 2026 - 05:55 UTC

Update

We continue to work with our cloud provider to scale additional resources. This process is taking longer than expected due to resource constraints reported by the provider, and we have been advised that scaling efforts may continue through the weekend. In parallel, we are performing optimizations within the existing environment to help reduce customer impact as much as possible.

During this time, some transactions may remain in a processing state longer than expected, and users may also experience delays or errors when attempting to open documents in Manual Review.

We understand how important timely processing and access to Manual Review are to our customers’ operations, and we are treating this issue with urgency. We will continue to provide updates as meaningful progress is made.
Posted Jun 25, 2026 - 00:17 UTC

Update

Our Engineering and Cloud Operations teams continue to work on increasing available capacity in the Vantage 3 EU region.

We are also working with our cloud provider to investigate challenges with scaling the environment. At this time, customers may continue to experience delayed document processing, with some transactions remaining in a processing state longer than expected. Users may also experience delays as documents move through the workflow or load in Manual Review.

We will provide another update as soon as additional progress has been made.
Posted Jun 24, 2026 - 19:25 UTC

Identified

We have identified that the processing delays in the Vantage 3 EU region are related to an unusual increase in load that is overwhelming the available processing resources.

Our engineering and cloud operations teams are actively working to increase available resources and restore normal processing performance. Customers may continue to experience delays while transactions are processed and the backlog is reduced.
We will provide another update as soon as additional progress has been made.
Posted Jun 24, 2026 - 16:23 UTC

Investigating

We are currently investigating reports of delayed document processing in the Vantage 3 EU region. Some transactions may remain in a processing state longer than expected, and users may experience delays when documents are moving through the workflow or loading in Manual Review.

Our engineering and cloud operations teams are actively reviewing the affected services and processing queues. We will provide an update as soon as more information is available.

We apologize for the disruption and appreciate your patience while we work to restore normal processing performance.
Posted Jun 24, 2026 - 15:27 UTC
This incident affects: Vantage Cloud 3.1 (EU).