FlexCapture Cloud US - Performance Degradation

Incident Report for ABBYY

Resolved

The issue has been fully resolved, and we have not observed any further reoccurrences. Thank you for your patience and understanding while we worked to restore normal operations.
Posted Aug 25, 2025 - 17:37 UTC

Monitoring

We have applied a fix and processing times should be stabilized. We are closely monitoring the situation.
Posted Aug 25, 2025 - 15:32 UTC

Investigating

We have observed performance degradation in FlexCapture Cloud US. You may experience slowness in document processing times. We are actively investigating the issue for a resolution and will keep you informed of any significant developments.
Posted Aug 25, 2025 - 14:53 UTC
This incident affected: FlexiCapture Cloud US.