FlexiCapture Cloud US - Performance Degradation

Incident Report for ABBYY

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 21:00 UTC

Monitoring

We are aware that our cloud provider is currently experiencing issues, which may impact some of our services. Our team is closely monitoring the situation and working to minimize any potential disruption. We’ll share updates here as soon as more information becomes available. Thank you for your patience.
Posted Sep 10, 2025 - 18:39 UTC

Investigating

We have observed performance degradation in FlexiCapture Cloud US. Analysis is currently in progress.
Posted Sep 10, 2025 - 16:36 UTC
This incident affected: FlexiCapture Cloud US.