Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2026 - 14:00 UTC
Scheduled
We are performing emergency maintenance on the ABBYY Vantage 3 EU environment to address performance degradation affecting transaction processing times.
The maintenance window is scheduled to begin at 14:00 UTC on June 27 and end at 15:00 UTC on June 27. This corresponds to 4:00 PM – 5:00 PM CEST on June 27.
During this window, we recommend avoiding the submission or processing of new transactions where possible. Transactions submitted during the maintenance window may process slowly or fail. Users may also experience brief delays or intermittent slowness when accessing or working in Manual Review.
Our team will be monitoring the environment closely throughout the maintenance activity and will provide further updates if there is any customer impact.
Posted Jun 26, 2026 - 14:31 UTC
This scheduled maintenance affected: Vantage Cloud 3.1 (EU).