FlexiCapture Cloud AU - Increase in pending tasks, delayed processing

Incident Report for ABBYY

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 08:24 UTC

Investigating

We are currently investigating instability in the FlexiCapture Australia environment. The pending task queue has been fluctuating — at times increasing, then decreasing, and rising again — rather than remaining stable. Customers may also experience slowness while processing the documents and also running Check Rules during the verification stage.

Due to the ongoing instability and customer impact, we have increased the severity of this incident to Major.

Our SRE team has worked on resource scaling and verification station checks, and our development team is actively investigating to determine whether recent release changes may be contributing. This remains our highest priority, and we will continue to provide updates as we work toward full stabilisation.

We appreciate your patience and understanding.
Posted Sep 02, 2025 - 07:22 UTC

Update

The backlog of pending tasks has continued to decrease and has been consistently below 100 for the past 30 minutes. Processing is stable, and no significant delays are expected. We are continuing to monitor closely.
Posted Sep 02, 2025 - 05:20 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2025 - 04:26 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2025 - 04:05 UTC

Monitoring

Our monitoring shows that while new tasks continue to enter the system, the backlog is being processed at the same time. The queue is stabilising, with a cap of around 400 pending tasks. This means the system is keeping up with the inflow, so you should not experience significant slowness in processing. Performance should remain steady as the backlog clears.
Posted Sep 02, 2025 - 04:05 UTC

Investigating

Dear Customer,

We would like to inform you that we are currently experiencing a minor increase in pending tasks within FlexiCapture Australia.

While documents are continuing to process, you might experience slight delays in completion. Please be assured that we are actively checking the system and working towards recovery.

Thanks,
Team Abbyy.
Posted Sep 02, 2025 - 03:38 UTC
This incident affects: FlexiCapture Cloud AU.