FlexiCapture Cloud US - Performance Degradation

Incident Report for ABBYY

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 23:25 UTC

Monitoring

We have implemented several measures which have improved the system's performance. All metrics are within the normal limits and we will continue to monitor the situation.
Posted Sep 16, 2025 - 21:58 UTC

Investigating

We are still getting reports of performance degradation. We are actively investigating the situation and will provide updates as soon as available.
Posted Sep 16, 2025 - 17:00 UTC

Identified

We have implemented a fix which should improve the system's performance. We are monitoring the situation closely.
Posted Sep 16, 2025 - 15:18 UTC

Investigating

We have observed performance degradation in FlexiCapture Cloud US. Analysis is currently in progress.
Posted Sep 16, 2025 - 14:32 UTC
This incident affected: FlexiCapture Cloud US.