We are continuing to work on the fix, and we will keep you posted as and when we have further updates.
Next Update will be at 8:00 AM UTC.
Posted Jun 25, 2026 - 05:55 UTC
Identified
Our Engineering and Cloud Operations teams continue to work on increasing available capacity in the Vantage 3 US region.
We are also working with our cloud provider to investigate challenges with scaling the environment. At this time, customers may continue to experience delayed document processing, with some transactions remaining in a processing state longer than expected. Users may also experience delays as documents move through the workflow or load in Manual Review.
We will provide another update as soon as additional progress has been made.
Posted Jun 24, 2026 - 19:26 UTC
Investigating
We are currently investigating reports of delayed document processing in the Vantage 3 US region.
Some transactions may remain in a processing state longer than expected, and users may experience delays as documents move through the workflow or load in Manual Review.
We have identified that the delays are related to an unusual increase in processing load, which is exceeding the currently available resources.
Our Engineering and Cloud Operations teams are actively working to increase available capacity and restore normal processing performance. Customers may continue to experience delays while transactions are processed and the backlog is reduced. We will provide another update as soon as additional progress has been made.