ABBYY FlexiCapture Cloud US - Increase in Pending Tasks

Incident Report for ABBYY

Resolved

The incident was resolved and the service work was restored.

Service reliability is a top priority for ABBYY, therefore we are continuously working on improving our systems.

Thank you for your patience. We bring our apologies for the inconvenience caused.
Posted Nov 15, 2025 - 02:20 UTC

Investigating

We observed an increase in pending tasks in the US region. You might experience some slowness while processing documents. Our engineering team is actively monitoring the situation to ensure it does not escalate.
Posted Nov 15, 2025 - 00:58 UTC
This incident affected: FlexiCapture Cloud US.