The mitigation actions have been completed, and service performance has returned to expected levels. Platform monitoring shows stable operation, and no additional customer reports have been received. This incident is now considered resolved.
Posted Jun 04, 2026 - 17:44 UTC
Update
Update: Cloud Operations has implemented a fix. Initial validation was completed by processing a test document, and performance appears to be back to normal. Awaiting confirmation from the customer on whether they are seeing the expected performance on their tenant.
Posted Jun 04, 2026 - 17:13 UTC
Investigating
Dear All,
We are currently investigating slow performance affecting ABBYY Vantage 2.7 in the EU region.
Customers may experience increased processing times or delays when using Vantage 2.7 EU. At this time, no other regions are affected.
Our team is urgently investigating the root cause and working to restore normal performance as quickly as possible. We will provide another update as soon as more information is available.